home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-wireless / prism54-20050724 / prism54-20050724.ebuild < prev    next >
Text File  |  2006-05-11  |  2KB  |  51 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /root/portage/net-wireless/prism54/prism54-20050724.ebuild,v 1.1.1.1 2006/03/22 23:30:35 grimmlin Exp $
  4.  
  5. inherit linux-mod
  6.  
  7. MY_P=${P/prism54-/prism54-svn-}
  8. S=${WORKDIR}/${MY_P}
  9. DESCRIPTION="Driver for Intersil Prism GT / Prism Duette wireless chipsets with injection patch"
  10. HOMEPAGE="http://prism54.org/"
  11. SRC_URI="http://10.1.33.200/divers/${MY_P}.tgz"
  12. LICENSE="GPL-2"
  13. KEYWORDS="~x86"
  14. IUSE="pcmcia"
  15. RDEPEND="net-wireless/prism54-firmware
  16.      net-wireless/wireless-tools"
  17.  
  18. MODULE_NAMES="prism54(net:${S}/ksrc)"
  19. BUILD_PARAMS="KVER=${KV_FULL} KDIR=${KV_DIR}"
  20. BUILD_TARGETS="modules"
  21.  
  22. CONFIG_CHECK="!PRISM54 NET_RADIO FW_LOADER"
  23. PRISM54_ERROR="You need prism54-firmware for the in-kernel driver or deselect
  24. the in-kernel driver to use the (probably older) driver from this ebuild."
  25. NET_RADIO_ERROR='You should enable "Wireless LAN drivers (non-hamradio) &
  26. Wireless Extensions"[CONFIG_NET_RADIO] in your kernel config'
  27. FW_LOADER_ERROR="Make sure you have CONFIG_FW_LOADER enabled in your kernel."
  28.  
  29. use pcmcia && CONFIG_CHECK="${CONFIG_CHECK} PCMCIA CARDBUS"
  30. PCMCIA_ERROR=CARDBUS_ERROR="General setup  --->
  31.     PCMCIA/CardBus support  --->
  32.         PCMCIA/CardBus support (m or y)
  33.         [*]   CardBus support (Important!)"
  34.  
  35. pkg_setup() {
  36.     linux-mod_pkg_setup
  37. }
  38.  
  39. src_unpack() {
  40.     unpack ${A}
  41.  
  42.     cd ${S}
  43.     epatch ${FILESDIR}/prism54-svn-20050724.patch
  44. }
  45.  
  46.  
  47. src_install() {
  48.     linux-mod_src_install
  49.     dodoc README ksrc/ChangeLog
  50. }
  51.